summary refs log tree commit diff
path: root/misc/ps1/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'misc/ps1/CMakeLists.txt')
-rw-r--r--misc/ps1/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/misc/ps1/CMakeLists.txt b/misc/ps1/CMakeLists.txt
new file mode 100644
index 0000000..1f78b62
--- /dev/null
+++ b/misc/ps1/CMakeLists.txt
@@ -0,0 +1,21 @@
+cmake_minimum_required(VERSION 3.21)
+
+project(
+	ClassiCube
+	LANGUAGES    C ASM
+	VERSION      1.0.0
+	DESCRIPTION  "ClassiCube PS1 port"
+	HOMEPAGE_URL "https://classicube.net"
+)
+
+add_definitions(-DPLAT_PS1)
+file(GLOB _sources ../../src/*.c)
+
+psn00bsdk_add_executable(template GPREL ${_sources})
+
+psn00bsdk_add_cd_image(
+	iso      # Target name
+	template # Output file name (= template.bin + template.cue)
+	iso.xml  # Path to config file
+	DEPENDS template system.cnf
+)