summary refs log tree commit diff
path: root/android/app/build.gradle
diff options
context:
space:
mode:
authorWlodekM <[email protected]>2024-06-16 10:35:45 +0300
committerWlodekM <[email protected]>2024-06-16 10:35:45 +0300
commitabef6da56913f1c55528103e60a50451a39628b1 (patch)
treeb3c8092471ecbb73e568cd0d336efa0e7871ee8d /android/app/build.gradle
initial commit
Diffstat (limited to 'android/app/build.gradle')
-rw-r--r--android/app/build.gradle29
1 files changed, 29 insertions, 0 deletions
diff --git a/android/app/build.gradle b/android/app/build.gradle
new file mode 100644
index 0000000..516e09a
--- /dev/null
+++ b/android/app/build.gradle
@@ -0,0 +1,29 @@
+apply plugin: 'com.android.application'
+
+android {
+    compileSdkVersion 28
+
+    defaultConfig {
+        applicationId = 'com.classicube.android.client'
+        minSdkVersion 13
+        targetSdkVersion 26
+        externalNativeBuild {
+            cmake {
+                arguments '-DANDROID_STL=c++_static'
+            }
+        }
+    }
+    buildTypes {
+        release {
+            minifyEnabled false
+            proguardFiles getDefaultProguardFile('proguard-android.txt'),
+                    'proguard-rules.pro'
+        }
+    }
+    externalNativeBuild {
+        cmake {
+            version '3.10.2'
+            path 'CMakeLists.txt'
+        }
+    }
+}